Follow

My Everyman Wireless Headset isn't working

If you are having any problems we suggest, as a routine first step, re-starting your computer.

Possible causes for your problem:

  • Ensure the headset is charged.
  • The volume in the operating system is too low.
  • Make sure the MUTE is not selected in your system settings.
  • The sound and audio devices settings are not set correctly.
  • Ensure the microphone is in the down position (i.e. at least 90 degrees to headband).
  • Try the USB dongle in a different USB slot to ensure it is reloaded.
  • Re-linking the headset and USB dongle. Press and hold the link (pair) button on the dongle for 5 seconds then press and hold the link (pair) button on the headset for 5 seconds or until the LED light is solidly lit. This forces the two components to re-link channels for communication.
  • The Skype settings may not be correct. Open Skype Go to Tools >Options >Audio settings. Click on drop box beside Microphone and Speakers. Change selection to FREETALK Everyman Wireless.
  • Ensure that the volume is not set too low to hear. Please test this by using the “Make a free test call” option. Your Voice and the Audio should register on the volume scale.
  • If you need further information please see www.skype.com/help/guides/ for complete instructions for Skype settings and usage.
  • If you are on a Mac, go to Skype >Preferences and select the Audio option. Change the Input and Output fields to the FREETALK Everyman Wireless option on the dropdown menu (NOT the Built-in).

If none of the above solves the problem try resetting the headset by inserting a paper clip into the pin hole near the charging cable slot.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

  • Avatar
    Crabpaws

    I've never been able to get a rational response from customer support on this product. Don't buy Freetalk products.

Powered by Zendesk